Back to overview
Resolved
CuppaZee Outage
Jun 19, 2026 at 5:10pm UTC
Affected services
CuppaZee API
CuppaZee Bouncers
CuppaZee Gardens
CuppaZee Push
CuppaZee OpenGraph Images
CuppaZee Gardens Scan
Resolved
Jun 19, 2026 at 5:27pm UTC
We should be back online. Apologies for the inconvenience.
Affected services
Created
Jun 19, 2026 at 5:10pm UTC
We're aware that CuppaZee and the in-app Munzdex, Redeem Store and Community Credits pages are down at the moment. We're investigating.
Affected services