Back to overview
Downtime

CuppaZee Gardens Outage

Nov 21 at 09:17am CST
Affected services
CuppaZee Gardens

Resolved
Nov 21 at 09:26am CST

CuppaZee Gardens should be back online.

Created
Nov 21 at 09:17am CST

We're aware of errors displaying when attempting to open Gardens in CuppaZee Gardens, and are now investigating.